Smartwork Access
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you are experiencing any remaining issues, please contact our support team: https://support.wwnorton.com/request
Posted Apr 20, 2020 - 09:43 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 20, 2020 - 09:40 EDT
Investigating
We are currently investigating reports of disrupted access to Smartwork. Our team is working to identify the root cause and implement a solution.
Posted Apr 20, 2020 - 09:37 EDT
This incident affected: Smartwork5.