Help desk issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
Access has been restored and customers should be able to submit support tickets. For help with Norton products, please visit https://wwnorton.com/help
Posted Dec 07, 2019 - 13:52 EST
Identified
We have identified the problem and are working on recovering help desk access to customers.
Posted Dec 07, 2019 - 12:12 EST
Investigating
We are investigating reports from customers who are unable to submit help desk tickets. We will post an update once the issue is identified.
Posted Dec 07, 2019 - 11:02 EST
This incident affected: wwnorton.com (main website).