Website service disruption
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. We will continue to monitor the fix closely. We apologize for the disruption.
Posted Jun 25, 2019 - 20:06 EDT
Identified
The issue has been identified and our teams are working on implementing a fix. Customers are currently unable to purchase Norton products or create new accounts. Customers with existing accounts are able to login to digital products as usual.
Posted Jun 25, 2019 - 17:24 EDT
Update
Customers with an existing account should now be able to access their digital products. However, users are currently not able to register new accounts or make online purchases at this time.
Posted Jun 25, 2019 - 12:15 EDT
Investigating
We are currently experiencing a website service disruption that limits customers' ability to login or purchase Norton products. Our website team is working to identify the root cause and implement a solution
Posted Jun 25, 2019 - 12:05 EDT
This incident affected: wwnorton.com (main website), Norton ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.