Website and digital product log-in issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you are experiencing any remaining issues, please contact our support team: https://support.wwnorton.com/request.
Posted Mar 21, 2020 - 20:05 EDT
Investigating
We are investigating an issue where customers are not able to log in to wwnorton.com or digital product pages. Our team is looking into this we'll provide an update as quickly as possible.
Posted Mar 21, 2020 - 17:36 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.