Possible credit card transaction failures due to national outage issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This issue has been resolved. If you need additional help, please contact support.wwnorton.com/request
Posted Aug 22, 2021 - 08:31 EDT
Identified
Due to a national outage with a credit card processor, customers may experience a credit card transaction failure when purchasing Norton products. We are monitoring the situation with the vendor.
Posted Aug 21, 2021 - 22:18 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, Smartwork5, Norton Testmaker, and Additional Digital Resources.