Help desk issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
The issue with the help desk form has been resolved.
Posted Jan 24, 2020 - 11:55 EST
Investigating
We are experiencing an issue with submitting help desk requests on our main website. Our team has identified the issue and is working quickly to fix it. We will post an update once the issue is resolved.
Posted Jan 24, 2020 - 11:46 EST
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.