Website service disruption
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Jul 31, 2019 - 06:52 EDT
Investigating
Due to necessary updates for the Norton network this morning, customers will be unable to make purchases, register a new account, change passwords, or contact the Help Desk. Our teams are working quickly and we will confirm when the work is complete.
Posted Jul 31, 2019 - 05:02 EDT
This incident affected: wwnorton.com (main website), Norton ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.