Digital products slow to load
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you experience any further issues, please contact our Support Team via support.wwnorton.com/request.
Posted Sep 13, 2021 - 01:02 EDT
Investigating
We are investigating reports that digital products are loading slowly or timing out. We will provide updates here. If you require assistance while we resolve this, please contact our Support Team via support.wwnorton.com/request.
Posted Sep 12, 2021 - 23:01 EDT
This incident affected: Norton Ebooks, InQuizitive, and Smartwork5.