Website and digital product service disruption
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you need further assistance, please contact our Support Team: https://support.wwnorton.com/request
Posted Jun 24, 2020 - 16:02 EDT
Monitoring
A fix has been implemented and we are monitoring the site. If you need further assistance as a result of the service disruption, please contact our Support Team: https://support.wwnorton.com/request
Posted Jun 24, 2020 - 15:04 EDT
Update
We are continuing to investigate this issue.
Posted Jun 24, 2020 - 14:47 EDT
Investigating
We are currently experiencing a website disruption. Digital products such as InQuizitive and Smartwork may also be impacted. Our support team is working to identify the root cause and implement a solution.
Posted Jun 24, 2020 - 13:45 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.