Technical Support Form page is down - support.wwnorton.com/request
Incident Report for W. W. Norton & Company, Inc.
Resolved
The support page and form are now loading again. If you experienced any issues during this incident and need further help, please contact support.wwnorton.com/request.
Posted Mar 30, 2021 - 08:41 EDT
Investigating
We are investigating reports that customers are not able to access or submit the form requesting technical support. Our development team is investigating, and we hope to restore the page and form soon.
Posted Mar 30, 2021 - 08:16 EDT
This incident affected: wwnorton.com (main website).