New account creation and purchases currently unavailable
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you need additional assistance please contact our Support team via support.wwnorton.com/request
Posted Dec 14, 2021 - 12:31 EST
Update
We have identified an issue with our website and digital products where customers are currently unable to create new accounts. Our team is working on the issue and will post updates here. If you need help in the meantime, please contact our Support team via support.wwnorton.com/request
Posted Dec 14, 2021 - 10:40 EST
Identified
We have identified an issue with our website and digital products where customers are currently unable to create new accounts. Our team is working on the issue and will post updates here. If you need help in the meantime, please contact our Support team via support.wwnorton.com/request
Posted Dec 14, 2021 - 10:15 EST
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, Smartwork5, Norton Testmaker, and Additional Digital Resources.