Norton digital products unavailable
Incident Report for W. W. Norton & Company, Inc.
Resolved
The incident has been resolved, and all sites are up and running again. If you experience any further issues please contact support at https://support.wwnorton.com/request.
Posted May 20, 2022 - 02:45 EDT
Update
We are continuing to investigate this issue.
Posted May 20, 2022 - 00:45 EDT
Investigating
We are currently investigate an outage of Norton's digital landing pages and website. We hope to resolve this quickly, and apologize for any inconvenience.
Posted May 20, 2022 - 00:41 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, Smartwork5, Norton Testmaker, and Additional Digital Resources.