Ebook and InQuizitive loading issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
We resolved the loading issue for ebooks and InQuizitive. If you experience any other issues, please contact Norton support at https://support.wwnorton.com/request
Posted Feb 25, 2021 - 16:46 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 25, 2021 - 10:21 EST
Identified
We have identified an issue that is preventing some ebooks and InQuizitive courses from loading. We are implementing a fix, and will provide an update when all titles are back online.
Posted Feb 25, 2021 - 09:57 EST
This incident affected: Norton Ebooks and InQuizitive.