Ecommerce issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved and ecommerce is restored.
Posted Jun 24, 2019 - 18:03 EDT
Update
We are continuing to investigate this issue.
Posted Jun 24, 2019 - 18:01 EDT
Update
We are continuing to investigate this issue.
Posted Jun 24, 2019 - 17:12 EDT
Investigating
We are currently experiencing an issue with ecommerce and the ability to purchase items on our site. Please contact us at support.wwnorton.com if you need assistance with a purchase.
Posted Jun 24, 2019 - 17:12 EDT
This incident affected: wwnorton.com (main website), Norton ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.