Search and catalog view not working on wwnorton.com
Incident Report for W. W. Norton & Company, Inc.
Resolved
The incident involving search on wwnorton.com has been resolved. If you need further help, please contact us via support.wwnorton.com/request.
Posted Nov 19, 2021 - 09:10 EST
Identified
We have identified an issue with the wwnorton.com site where the search and catalog view are not working. Our team is working on the resolution and we will post updates here. Should you need help in the meantime, please contact us via support.wwnorton.com/request
Posted Nov 19, 2021 - 08:38 EST
This incident affected: wwnorton.com (main website).